{!items to fill manually!}
1. FLASH OPENWRT
2. SET PASSWORD, WRITE IT DOWN!
2.1. SET DROPBEAR TO LAN!
3. SSH IN (NO host verification! It will raise problems if you reflash.)
4. ADHOC.
Important: despite what the doc used to say, {!name!}.relais.reseaulibre.ca is NOT supported. It breaks Babel.
SSH:
uci delete wireless.radio0.disabled
uci set wireless.radio0.channel=1
uci set wireless.@wifi-iface[0].mode=adhoc
uci set wireless.@wifi-iface[0].ssid=relais.reseaulibre.ca
uci set wireless.@wifi-iface[0].bssid=02:CA:FF:EE:BA:BE
uci set wireless.@wifi-iface[0].network=wan
uci commit
5. IPV4.
DIVERGENCES FROM THE FULL DOC AHEAD! CAREFUL.
SSH:
uci set network.wan=interface
uci set network.wan.ifname=wlan0
uci set network.wan.proto=static
uci set network.wan.ipaddr=172.16.{!addr!}.{!addr!}
uci set network.wan.netmask=255.255.255.255
uci commit
Q: Why not uci set network.wan.netmask=255.240.0.0?
A: It will rebroadcast 172.16.0.0 from 0.0.0.0. ...Why? Not too sure yet.
6. (Optional) EXISTING LAN INTEGRATION.
WEB INTERFACE:
Interfaces -> LAN -> Protocol -> instead of Static Address, choose DHCP client
Plug that thing into the net and hope... worst case, factory reset and start again
7. IPV6
Use the web interface to configure.
fd64:2c08:9fa7:{!something!}::1
is the one I'm using. For smaller nodes, use
fd64:2c08:9fa7:{!something!}:{!something!}:1
8. BABEL.
SSH:
opkg update
opkg install babeld
/etc/init.d/babeld enable
uci delete babeld.wan.ignore
In /etc/babeld.conf put:
# mesh IPv6
redistribute local ip fd64:2c08:9fa7::/48 metric 128
redistribute ip fd64:2c08:9fa7::/48 metric 128
# mesh IPv4
redistribute local ip 172.16.0.0/12 metric 128
redistribute ip 172.16.0.0/12 metric 128
redistribute local deny
redistribute deny
Open /etc/config/babeld, change:
option 'ifname' 'wlan'
to
option 'ifname' 'wlan0'
Remove ignore 'true' above that also.
And uncomment conf_file and log_file.
Firewall settings:
config rule
option name Allow-Babel
option src wan
option dest_port 6696
option proto udp
option target ACCEPT
If you're testing and one side can't see each other, check firewall settings on both ends.
?. STYLE POINTS:
Change /etc/banner to be fancy
Change your MAC address from the web interface